Forums » Announcements Search

Version 3 of the APIs will be sunset on Feb 1, 2011 New Reply

Author Post
Posts: 1075
Registered: Sep 08, 2008

Hey all:

We released version 4 our our API back in July of 2010. At that time we indicated that support for version 3 of the API would stop at the end of 2010. We have now picked Feb 1, 2011 as the date when V3 will be turned off. Calls made to V3 of the API will no longer work after Jan 31, 2011.

What does this mean for you? If you already using V4 of the APIs you do not need to do anything. Likewise, if you are using a recent version of Pyechonest (our Python client), Remix or jEN (our Java client), you are already using V4 and don't need to do anything. If, however, you are using V3 of our APIs, then you will need to switch to V4 by Feb 1, 2011, otherwise your application will stop working. But, really, you should already by using V4 since it is faster, has many more features and supports all sorts of coolness like Rosetta Stone, JSON, JSONP and so on.

Paul

Posts: 1075
Registered: Sep 08, 2008

Sometime in the next 48 hours, our machines that host V3 of the Echo Nest API will be shutdown. We announced the shutdown of V3 last year here: http://developer.echonest.com/forums/thread/280

This is the final notice. This week we will actually turn the machines off.

If your application is still using V3 of the API, once we shutdown V3 your calls will no longer work. If the application making the calls is important to you, you should switch it over to use V4 of our API. It is faster, has more features and is more stable.

Please let me know if you have any questions.

Paul

Reply to this Thread

You must log in to post a reply.